Most pump issues are easy to fix and can often be resolved in minutes. Carrying out regular checks and maintenance can prevent persistent pump problems so you can get back to enjoying your Lay-Z-Spa.Get help with your Lay-Z-Spa pump. Find out the causes and the solutions to pump error codes, noisy pump issues, heating problems and much more.

E01

Description
Cause
Solution
Sensor Error
The water flow sensors’ flags didn’t come back into the correct position.

Unplug the pump unit, lightly strike the side of it and then plug it back in.

Water Flow Error

Electrical issue. Can occur when the spa is not plugged into a mains socket. May also be an issue with the RCD socket.

If the unit does not respond, try rolling the pump unit on its side in order to shift the sensor placement.
Debris Buld Up
Issue with water flora sensors due to debris build up.

Please follow the backwash procedure in the video here

E02

Description
Cause
Solution
Water Flow Error

The stopper caps are still inside the spa.

Remove the black stopper caps from the inside of the liner before heating, filtering or running the bubbles on the spa. If you are unsure how to remove them, please refer to the assembly section within the Lay-Z-Spa owners manual.

Filter cartridges are dirty

Remove the filter cartridge from the filter housing and check it is clean. Please make sure the new filter is clean and dry before you install it.

Filter housing is restricting flow

Remove the filter housing from the liner and check the black membrane inside. These should lie flat inside the housing. If they are ok, continue to run the spa without the filter cartridge attached and see if the error code persists. Ensure that the debris screens are clear of debris.

Pipes within the liner are kinked or bent.

Disconnect the pump and check the pipes inside the liner. You can manipulate these with warm water to return them to the correct shape.


Washers perished inside pump couplings

Disconnect the pump from the liner. Check the condition of washers inside the couplings on the pump. We would suggest backwashing the pump to clear any debris. If the washers are perished you can purchase spares from Here


Water flow sensors not working

If the above troubleshooting has not resolved the problem, the water flow sensors may not be working. Please contact us for more help with this




E03

Description
Cause
Solution
Temperature too lowThe pump will only operate when the ambient temperature is above 4°C. We would suggest disconnecting the pump and moving it to a warmer place. You will need to do the thermal reset procedure before continuing use.

The pump will only operate when the ambient temperature is above 4ºC.


The pump thermometer is broken.

If your pump is displaying this message and the ambient temperature is above 4ºC. Please contact us for more help.

E04

Description
Cause
Solution
Temperature too highThe pump unit has overheated.

Place the stoppers caps inside the spa and disconnect the pump unit. Allow time for the pump unit to cool down before connecting again.


The water temperature is over 50ºC (122ºF).

The Lay-Z-Spa is not designed to operate with water temperatures exceeding 40ºC (104ºF). Unplug the pump and plug it back in once the water temperature has reached 38ºC (100ºF) or lower. IMPORTANT: Before you restart the pump, press the reset button.


The thermostat needs resetting.

  • Watch the Thermal Reset Video
  • Turn the pump unit on at the mains.
  • Press the test button once and leave it bleeping (leave for 10 seconds).
  • Turn the pump unit off and unplug from the socket (leave for 10 seconds).
  • Plug the pump unit back in and turn it back on.
  • Press the thermal reset button for 10 seconds using a pencil or screwdriver (see Owner’s Manual for location)
  • Once done, press the heater button. Your pump should now be working.

E05

Description
Cause
Solution

Temperature too high

The thermostat is broken.

If the troubleshooting has been completed without success, please contact us Bestway for more help with this



  • Watch the Thermal Reset Video
  • Turn the pump unit on at the mains.
  • Press the test button once and leave it bleeping (leave for 10 seconds).
  • Turn the pump unit off and unplug from the socket (leave for 10 seconds).
  • Plug the pump unit back in and turn it back on.
  • Press the thermal reset button using a pencil or screwdriver (see Owner’s Manual for location).
  • Once done, press the heater button. Your pump should now be working.

Pump unit needs to be cleaned

Try the back wash procedure.


Not enough power to the pump.

Ensure the pump unit is plugged into a mains socket and not an extension lead.

E06

Description
Cause
Solution
Electrical Fault The power port has experienced a temporary current variation.

Unplug the pump and hen plug it back in. Please ensure the pump unit is plugged into a mains socket and not an extension lead.

E07

Description
Cause
Solution
Electrical Fault

The pump has read an electrical error.

Try the reset procedure detailed in the troubleshooting document. If the troubleshooting has been completed without success, please contact us for more help.

E08

Description
Cause
Solution

The thermostat needs resetting.
  • Watch the Thermal Reset Video
  • Turn the pump unit on at the mains.
  • Press the test button once and leave it bleeping (leave for 10 seconds).
  • Turn the pump unit off and unplug from the socket (leave for 10 seconds).
  • Plug the pump unit back in and turn it back on.
  • Press the thermal reset button using a pencil or screwdriver (see Owner’s Manual for location).
  • Once done, press the heater button. The pump should now be working.

E09

Description
Cause
Solution
Fuse Failure. Internal fuse failure or has become disconnected within the pump.
  • Turn the spa completely off.
  • Turn the power off at the socket.
  • Remove the plug from the socket for the pump.
  • Press the following buttons on the PRCD – Reset –> Test –> Reset.
  • Turn the pump back on, using the On/Off button on the display.
  • Please ensure you hold your finger down for at least 10 seconds.
  • If the troubleshooting has been completed without success, please contact Bestway for more help.

E10

Description
Cause
Solution

High salt alarm.

Alarm where too much salt has been added to the spa or a large amount of water has evaporated.

  • Do not use the spa or place any further Pure Spa Salt for 24 to 48 hours to ensure the levels reduce. Unplug the spa pump, remove from the liner and drain 20% of the water from the spa. Refill this with fresh water.
  • Start the Salt Chlorinator System.

E11

Description
Cause
Solution
Low salt alarm. Alarm for low salt levels within the spa. This means the spa requires further salt to be added.


  • Unplug the spa pump from the electricity, wait 10 seconds then plug the spa back in.
  • Reset the spa as first use using the reset button.
  • Once reset, turn on the Hydro Jet system.
  • Gradually add and dissolve 0.5kg (500g) of Pure Spa Salt at a time.
  • Start the Salt Chlorinator System.
  • Allow the spa pump to run on either the 5 hour or 8 hour setting.
  • If the E11 error code is visible again, place a further 0.5kg (500g) of Pure Spa Salt in the spa.


E12

Description
Cause
Solution
Water Leakage Error code for an issue with water leaking within the body of the pump.
  • Check the couplings on the pump connections to ensure there is no water leaking from these.
  • Also ensure the washers within these are flat.
  • These can be checked using a screwdriver and simply unscrewing the coupling.
  • If these are dry and tight, please contact Bestway Aftersales as there may be a leak within the pump.
  • Please do not attempt to reset or use the pump whilst the E12 error code is visible.

E13

Description
Cause
Solution
Signal within the pump.

Error code for issue where the electrical signal within the pump body between the control panel and power board has become disconnected.

  • This error code can become visible on 2017 model pumps and newer.
  • The date of the spa pump can be located on the silver sticker on the pump body itself (S/N Number) or engraved within the handles.
  • If this error code does become visible, please contact your Bestway Warranty Department as the pump will need to be either replaced or repaired.
  • As this is an issue with the signal between two components within the body, please do not attempt to repair or open the pump.

GCF

Description
Cause
Solution
Not grounded/earthed correctly An issue with your power supplyRemove any extension leads, we do not recommend the pump is run on one of these. Also try the pump in an alternative socket. If the issue persists, please contact us for further advice.